Indisponibilidade da biblioteca spring-security-facelets-taglib

Recentemente a biblioteca spring-security-facelets-taglib foi movida do GoogleCode para o GitHub.

O Google também fornecia o repositório Maven e que era utilizado no projeto do livro no capítulo 6, arquivo pom.xml. (seção 6.6)

Infelizmente a biblioteca ainda não foi movida para outro repositório, mas já entramos em contato com o autor, e será colocada no repositório central do Maven nos próximos dias.

Enquanto isso não acontece e continuar gerando erro de dependência no arquivo pom.xml recomendamos que substitua o uso da tag <sec:ifAnyGranted> pelo exemplo abaixo:

<h:panelGroup rendered=”#{request.isUserInRole(‘ROLE_ADMINISTRADOR’)}”>
conteudo a ser restringido
</h:panelGroup>

Para o projeto do livro não há perda de funcionalidade com esta substituição, porém a biblioteca em si tinha mais opções do que somente o “isUserInRole”.

O uso da tag <sec:ifAnyGranted> poderá ser retomado quando a biblioteca estiver disponível no repositório central do Maven.

Avisaremos pelo blog quando isto acontecer, caso queira ser avisado, mande um e-mail para o endereço de suporte ao leitor do livro, e entraremos em contato.

Tags:

Comments are closed.